Back to overview
Resolved

Dashboard is experiencing instability

Aug 19, 2026 at 9:36pm UTC
Affected services
Canadian SaaS Infrastructure
US Infrastructure
Australian SaaS Infrastructure
pressbooks.pub

Resolved
Aug 19, 2026 at 10:33pm UTC

What happened:

Our hosting infrastructure runs on Ubuntu Linux, maintained by Canonical. Canonical released a security patch for nginx (the web server software that handles traffic to your book sites), version 1.24.0-2ubuntu7.16, addressing a legitimate vulnerability. As we do with all security patches from this trusted source, we applied it to our servers.

Shortly after, Canonical identified that this specific patch had an unintended side effect: it changed some internal software interfaces in a way that broke compatibility with third-party components other software relies on. This caused admin dashboards (/wp-admin/) to become inaccessible for logged-in users, appearing as an infinite redirect loop in the browser.

What we did:

As soon as we identified the cause, we rolled back the affected servers to the previous, stable version (1.24.0-2ubuntu7.15). Dashboard access was restored and has been stable since.

Going forward:

Canonical has since released 1.24.0-2ubuntu7.17, a corrected patch that addresses the original security issue without the compatibility problem. We'll be applying this update in a controlled rollout soon, and don't expect any disruption this time.

We apologize for the inconvenience and are happy to answer any questions.

Updated
Aug 19, 2026 at 9:47pm UTC

We have restored functionality to the dashboards, and are monitoring the system for any further issues while we investigate the root cause.

Created
Aug 19, 2026 at 9:36pm UTC

The book dashboard for some users is causing an infinite redirect problem. We are investigating the issue and respawning systems that are reporting back errors.